Easy Jmol Web Pages using the Jmol Export to Web Function

By Jonathan Gutow, November 2008 (updated August 2009)
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 TC "Overview" \l 1 Overview

The export to web function in Jmol automatically generates some simple web pages that display views you design within the Jmol application. You can edit the pages created using a standard web editor to change the text and add features, such as pictures and tables. These automatically generated pages are also a good starting point for more complicated pages that require some hand coding. There are some alternative packages for generating Jmol based web pages that require additional software or operate from servers (see appendix 10).  This printed tutorial was created for Jmol version 11.6. A web based tutorial that will be kept updated as the export to web function changes is accessible from the tutorials section of the jmol wiki (wiki.jmol.org). As of version 11.6 there are two simple templates:

	Pop-in: this template allows you to create a page with multiple images of your Jmol views.  When a user clicks on one of these pictures, it becomes a live Jmol applet that can be rotated, zoomed etc. 
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Figure 1: Cartoon of the Pop-in style page.
	ScriptButton: this template displays a single Jmol applet on the right side of the browser window.  On the left side is a scrolling region with buttons that allow the user to select the view. 
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Figure 2: Cartoon of the Scriptbutton style page.


Possible future enhancements include: 1) addition of optional buttons that do common things to Jmol views, such as spin the molecule or change the background color; 2) a new template for a table of Jmol applets; and 3) other requests as they are made by users.

To create pages with either of these formats start Jmol and open a file containing the molecular information you want to view. Jmol reads many file formats including .pdb, .cif, .mol, gaussian and gamess output files.  For this tutorial I will use the gamess .log
 output file from an optimization of the geometry of staggered ethane.  If you wish to follow along you need the file : ethane-staggered-3-21G.log.  A copy is packaged with the .pdf version of this document.  You can also download it from the tutorial web site.  Many of the pages in the web tutorial were generated using the Jmol Export to Web function.  An .html version of this tutorial that works much like the tutorial web site and shows off some of Jmol's capabilities is also packaged with the .pdf version of this document.  Open the document "Export_to_Web_Tutorial_Index_Menu.html" in the "How-To" folder using Safari on MacOS and Firefox on Windows and Linux for the best results.

 TC "Getting started (starting Jmol and opening a file)" \l 1 Getting started (starting Jmol and opening a file):

 Skip to making a web page if you already have Jmol and can load structures into it.
1. If you haven't, Download Jmol: Get the latest stable version from the Jmol web site (www.jmol.org[image: image3.png]


). Once there follow the download links. Once downloaded you will have to "unzip" the compressed file.

2. Make sure you have a Java Virtual Machine (JVM) Installed:  This is the default on MacOS X and recent Windows XP/Vista systems.  Most Linux systems require you to install the JVM.  To perform an installation follow the instructions for your particular system.  The Sun Java [image: image4.png]


(www.java.com) system is recommended.
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Launching Jmol: On your computer find the file, Jmol.jar. 

· On MacOS X simply double click the Jmol.jar file to launch the program.

· On Linux double-clicking Jmol.jar may default to uncompressing the .jar file. In that case you will need to launch it from a command line ("java -jar Jmol.jar") or use your GUI "Open with ..." functionality which is usually available by right clicking on the icon.  

· On Windows the file may be difficult to identify, because by default the extensions are hidden and there are a number of files called Jmol.XXX, with different extensions. To show the extensions go to the Tools menu and select "Folder Options...".  In the dialog that opens select the "View" tab and scroll down to "Hide Extensions for Known File Types".  Uncheck this option.  Click "Apply" and then "OK".  Double clicking on Jmol.jar may work, but not always (it depends on exactly which version of Windows). You may be able to get it to work using javalauncher [image: image5.png]


(www.syncedit.com/software/javalauncher/). Otherwise right click on the icon and use the "Open with.." menu item. Select "Java Platform..." and click "OK". If this does not work and you do have a java virtual machine installed, open the command prompt; navigate to the proper directory and type "java -jar jmol.jar". 

4. Opening a file: In the file menu select "Open..." Use the open file dialog to navigate to the directory your file is stored in. Select the file and click "Open". If the file is of a type that Jmol can read a picture of a molecule should appear. 

 TC "Make a web page" \l 1 Make a web page:

1.  TC "Familiarize yourself with Jmol." \l 2 Familiarize yourself with Jmol. If you already know how to make Jmol display measurements, orbitals, change atom size and things like that skip to step 2. Otherwise try these links to the appendices on getting Jmol to display the molecule the way you want ( [image: image6.png]


 indicates an external web site):  Zoom | Rotate | Set Spinning | Change Atom Size | Change Bond Size | Make and Show Measurements | Make Cartoon Views of Biomolecules | Displaying Orbitals | Using Commands in the Script Window | Navigating within a Multiframe (multi-image) File | Adding Your Own Text | LCAO Cartoons[image: image7.png]


 | Displaying Crystallographic Information[image: image8.png]


 | Bob Hanson's Scripting Documentation[image: image9.png]


 | Much more about Jmol and its capabilities (the Jmol Wiki)[image: image10.png]


. 

2.  TC "Make web pages using the Jmol Web Page Maker dialog." \l 2 Make web pages using the Jmol Web Page Maker dialog. 
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General setup that is common to all templates. 

1. Open the Jmol Web Page Maker dialog by clicking on the "Export to Web Page..." icon [image: image11.png]


 or by selecting "Export to Web Page..." within the "Export" submenu of the "File" menu. A dialog box should appear. 

2. Select one of the template tabs by clicking on it (I will use the Pop-in template as an example). See Figure 4. 

3. The fields on the left side of the dialog contain general setup information that is used to make the Jmol Applet work on your server (see the appendix for instructions on installing the applet on your server).  The "Help/Instructions" button provides a brief version of the information in these tutorials. 

4. In the top text field set the relative path on the SERVER (directions to the directory) to Jmol from the directory that will contain your web page.  Use a "../" for each level you move up in the directory structure from where your page will be stored followed by names for each level down.  Example: Jmol jar files and Jmol.js are in the directory "/www/applets/java/jmol" on the server, and you will be creating the directory "/www/yourname/thispage" to hold the HTML files and other data files. The correct path to the Jmol applet is then "../../applets/java/jmol" (up two to the www directory and then down to the jmol directory). 

5. In the second text box set the relative path on your computer to the Jmol applet.  This allows you to test the pages without uploading them to the server (on Macs you must use Safari for testing because of security issues).  The directory containing the .html file must be a subdirectory of the directory containing the Jmol applet.  There are two ways to do this: 

· Simple but inefficient of disk space.  Just put a "." in this field.  A copy of the applet will be packaged in the same directory as your .html file.  This means you will have as many copies of the applet on your disk as pages generated by Jmol. 

· More difficult but much more efficient. 

· Create a directory (folder) named something like "tests" inside the directory on your local machine that contains the Jmol applet. 

· Specify the local path to Jmol as "../../" when you create the page in Jmol Web Page Maker. 

· Copy or move the directory (not just its contents) containing the .html, .spt, .png and .js files for the page of interest into the directory created in the first step. 

· Open the .html file in the browser you want to use for testing (use Safari on MacOS X as FireFox does not pass relative paths causing a security error).  The page should work just like it would on a server. 

6. Put in your name as the author. 

7. Pick a descriptive title for the page. 

·  TC "The Pop-In Template" \l 2 The Pop-In Template

1. Make sure that you have selected the PopIn tab and that the information on the left-hand side of the dialog box is filled in properly (see general set-up, above).

2. [image: image26.png]Jmol



Make the first view:

· Open the scripting console (right mouse button, control-click on one button mouse, > Console).

· Navigate to the last frame of the file. Use either the command "frame 1.9" or the pop-up menu (right mouse button > model > 1.9).

· Display the measurements using the command: "measure all connected (*)(*)". See figure 5.

· Save this view by clicking on the "Add Present Jmol State as Instance..." button near the bottom right of the dialog.

· Enter the text you want to appear in the button in the small dialog that pops up.  I suggest "Ethane Bond Lengths".  Click "OK".  This will add this instance to the list in the large window on the right side of the dialog box.
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Make the second view:

· Remove the measurements using the command: "measure off".

· Display the molecular orbital using the command: "mo 9".  See figure 6.

· Turn on spinning using the command: "spin on".

· Save this view by clicking on the "Add Present Jmol State as Instance..." button near the bottom right of the dialog.

· Enter the text you want to appear in the button in the small dialog that pops up.  I suggest "Ethane HOMO b".  Click "OK".  This will add this instance to the list in the large window on the right side of the dialog box.

· Note this view could also be created using the menus.

4. Go to creating the web page to see how to save this as a web page.

·  TC "The ScriptButton Template" \l 2 The ScriptButton Template

1. Make sure that you have selected the ScriptButton tab and that the information on the left-hand side of the dialog box is filled in properly (see general set-up, above).

2. [image: image28.png]ethane-staggered-3-21G.1log
Model 1.1 MO 8/49

Energy = -0.4773

Symmetry = A

MO #8 one of two degenerate hitpy!



Make the first button:

· Open the scripting console (right mouse button, control-click on one button mouse, > Console).

· Navigate to the last frame of the file. Use either the command "frame 1.9" or the pop-up menu (right mouse button > model > 1.9).

· Turn on spinning (right mouse button > Spin > On).

· Display MO #8.  Use either the command "mo 8" or the pop-up menu (right mouse button > Surfaces > Molecular Orbitals > 1..25 > 8 -0.4773)

· Add the annotation at the bottom using the echo command: "set echo bottom center; echo "MO #8 one of two degenerate HOMOs"".  It should now look like figure 7.

· Save this view by clicking on the "Add Present Jmol State as Instance..." button near the bottom right of the dialog.

· Enter the text you want to appear in the button in the small dialog that pops up.  I suggest "MO 8".  Click "OK".  This will add this instance to the list in the large window on the right side of the dialog box.

3. Make the second button:

· Display MO #9.  Use either the command "mo 9" or the pop-up menu (right mouse button > Surfaces > Molecular Orbitals > 1..25 > 9 -0.4773)

· [image: image29.png]ethane-staggered-3-21G.1log
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Change the annotation to reflect the change in orbital using the command: "echo "MO #9 one of two degenerate HOMOs"".  It should now look like figure 8.

· Save this view by clicking on the "Add Present Jmol State as Instance..." button.

· Enter the text you want to appear in the button in the small dialog that pops up.  I suggest "MO 9".  Click "OK".  You should now have two instances in your instance list.

4. Make the third button:

· Turn off the display of MO #9 with the command: "mo off".

· Create the cyan display of MO #8 with following commands:

· [image: image30.png]cyan (MO#8)
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"isosurface homoa mo 8 mesh nofill;"

· "color isosurface cyan;"

· Create the yellow display of MO #9 with the equivalent commands:

· "isosurface homob mo 9 mesh nofill;"

· "color isossurface yellow;"

· Change the annotation to reflect what is now displayed using the command: "echo "Cyan (MO#8)|Yellow (MO#9)"".  The line right before the word "yellow" is a vertical line, usually found as the shift character for the backslash "\".  This vertical line causes everything after it to appear on a new line.  It should now look like figure 9.

· Save this view by clicking on the "Add Present Jmol State as Instance..." button.

· Enter the text you want to appear in the button in the small dialog that pops up.  I suggest "HOMO Comparison".  Click "OK".  You should now have three instances in your instance list.

·  TC "Creating the web page" \l 2 Creating the web page

1. Double check your entries in the text boxes on the left side of the dialog box (you may not have reset them since making a different web page).

2. Click on the "Save .html as ..." button near the bottom left.  Choose a location and name for the page.  A directory of that name will be created in the location you choose.  It will contain many files.

3. Check that your page is OK. If necessary move a copy of the whole directory just created to your test directory (see instructions on testing locally in the appendix).  Open the .html file.  In an web browser your file should look like figure 1 or 2.

4. Add any descriptive text, figures or other information you wish.  You only need to edit the .html document.  

5. Open the .html document in your favorite WYSIWYG Web page editor.  Some suggestions are: 

· KompoZer[image: image12.png]


 (open source, reasonably good),

· SeaMonkey[image: image13.png]


 (open source, but a little behind),

Amaya[image: image14.png]


 (open source, complete, but harder to use).

6. Be careful when editing not to do anything to the picture of Jmol at right or inside the boxes (tables) that will contain the buttons.  It is possible to damage the javascript so that the page will not work.

7. There is a known problem with some of these editors messing up the javascript in the headers created by Jmol 11.4.4.  This can be fixed by manually editing the source code.   Search for the text "one file;" near the top of the file.  It will probably be at line 38 or so.  Replace the ";" with a <return> and make sure that the next line is:

· var dataDir = ".";  //some comments.

8. Once the page is the way you want it copy the whole directory containing the file to your web server in the appropriate directory.

9. You're done!

Appendices

 TC "Appendix 1: Common Ways to Manipulate the View in Jmol" \l 1 Appendix 1: Common Ways to Manipulate the View in Jmol

To zoom the image in Jmol put the mouse cursor over the Jmol image then hold down the shift key and the left mouse button while dragging down to zoom in or up to zoom out.  For some mice the scroll wheel also works.  Fixed zoom levels are also accessible in the pull-down menus of the application (Display > Zoom > XXX%) and the pop-up menu in both the application and the web applet (Left mouse button, control-click on one button mice, > Zoom > XXX%). 

To rotate the image in Jmol put the mouse cursor over the Jmol image then hold down the left mouse button while dragging the cursor around.

To start spinning the molecule using the default spin settings use the pop-up menu in both the application and the applet (Left mouse button, control-click on one button mice, > Spin > On). 

To stop the spinning of the molecule use the pop-up menu again (Left mouse button, control-click on one button mice, > Spin > Off). 

To have spinning about axes other than Y select the rate (degrees per step) for rotation about the X or Z axis.  Use the pop-up menu (Left mouse button > Spin > Set X (Y or Z) Rate > XX).  The default Y rate is 30 and 0 for X and Z rates.  The axes are screen axes:  Y is up-down, X is left-right, Z is in-out of the screen. 

To change the atom size use the pull-down menus of the application or the pop-up menu in the application and the applet.  Fixed percentages of the Vander Waals radius are available.  Pull-down menu (Display > Atom > XXX%).  Pop-up menu (Left mouse button, control click on one button mice, > Style > Atoms > XXX %). 

To change the bond size use the pull-down menus of the application or the pop-up menu in the application and the applet.  Pull-down menu (Display > Bond > XXX). Pop-up menu (Left mouse button > Style > Bonds > XXX).  You can also quickly select some common combinations of atom size and bond from the pop-up menu (Left mouse button > Style > Scheme > XXX).  The options are: CPK spacefill; Ball and Stick; Wireframe.  Wireframe is also available in the pull-down display menu in the Bond submenu. 

To measure bond lengths double click on the first atom.  The cursor will convert to a "+".  Move the cursor to the second atom.  Double click on the second atom.  The distance between the atoms will be shown.  Using the pop-up menu you can choose between units of nm, angstroms and pm (Left mouse button, control-click on one button mice > Measurement > XXX).  You can also display all the bond lengths at once using the command line.  The command is: "measure allconnected (*)(*)" See Using Commands in the Script Window.

To measure bond angles double click on the first atom.  The cursor will convert to a "+".  Move the cursor to the second atom.  Click ONCE only on the second atom.  Move to the third atom and double click on it.  The angle made by these three atoms will be displayed.

To measure dihedral angles (the angle between two bonds) double click on the first atom.  The cursor will convert to a "+".  Move to the second atom and click once.  Move to the third atom and click once.  Move to the fourth atom and double click.  This will display the angle made by the line between atoms 1&2 and the line between atoms 3&4.

To make cartoon views of biomolecules use the pop-up menu.  There are a large number of options. An annotated .pdb file from the protein data bank (http://www.rcsb.org/) is necessary to use this feature.  To practice you can use the file of a protein/DNA complex included with this tutorial: 1lcd.pdb1.gz  

First, select the part of the structure you want to work with.  Use the pop-up menu (Right mouse button, control-click on one button mice, > Select > choose among the options.)
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Second select the desired representation.  Use the pop-up menu (Right mouse button > Style > Scheme or Structure > XXX).

Some things to try with the  suggested file:

1. Render the DNA as a violet cartoon: 

· select DNA (Right mouse button > Select > Nucleic  > All).

· Render as cartoon (Right mouse button > Style > Scheme > Cartoon).

· Make the cartoon violet (Right mouse button > Color > Structure > Cartoon > Violet).

2. Render the protein as space filling with the polar groups in red.

· select the protein (Right mouse button > Select > Protein > All).

· Render as spacefilling (Right mouse button > Style > Scheme > CPK spacefill).

· Make the whole protein cyan (Right mouse button > Color > Atom > Cyan).

· Make the polar residues red (Right mouse button > Select > Protein > Polar Residues). Then (Right mouse button > Color > Atom > Red).  See figure A1.1.

3. Render the protein as a cartoon.

· select the protein (Right mouse button > Select > Protein > All).

· Render as cartoon (Right mouse button > Style > Scheme > Cartoon).

 TC "Appendix 2: How to Display Orbitals" \l 1 Appendix 2: How to Display Orbitals

1. Load a file that contains orbital information (output of a quantum package) into the Jmol application.  You can use the staggered ethane file packaged with the .pdf version of this document:  ethane-staggered-3-21G.log.  It can also be downloaded from the tutorial web site. 
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Advance to the last "frame" because the quantum software puts the optimized orbital information in the last "frame".  Use the pull-down menu in the Jmol application (Tools > Animate > Once)  or the pop-up menu in both the application and the applet (right mouse button, control click on a one button mouse, > Model > select the last one, bottom choice).

3. Start the molecule spinning.  Use the pop-up menu in both the application and the applet. (right mouse button > Spin > On). 

4. Display your first orbital.  In the application or the applet use the pop-up menu (right mouse button > Surfaces > Molecular Orbitals > 1..25 > #3 - 1.013).  This will display the third orbital with an energy of -1.013 Hartrees.  This should look like figure A2.1.

5. Display the two HOMOs (Highest Occupied Molecular Orbitals).  These are the degenerate orbitals number 8 and 9.  Use the pop-up menu (right mouse button > Surfaces > Molecular Orbitals > 1..25 > #8 - 0.4773) and (right mouse button > Surfaces > Molecular Orbitals > 1..25 > #8 - 0.4773). 

6. Display the LUMO (Lowest Unoccupied Molecular Orbital).  This is orbital number 10.  Use the pop-up menu (right mouse button > Surfaces > Molecular Orbitals > 1..25 > #10 0.274).  The button below will generate the display you should have.

7. Many more options for orbital display are available by using the commands "mo" and "isosurface" in the scripting window.  A brief tutorial on using commands in the script window may be found in appendix 3.  Detailed documentation on scripting may be found in  Bob Hanson's Scripting Documentation[image: image15.png]


.

 TC "Appendix 3: Using Commands in the Script Window" \l 1 Appendix 3: Using Commands in the Script Window

1. Load a file that contains some carbon and hydrogens into the Jmol application.  You can use the staggered ethane file packaged with the .pdf version of this document:  ethane-staggered-3-21G.log.  It can also be downloaded from the tutorial web site. 

2. [image: image33.png]


Open the script window.  In the application use the pull-down menu (File > Script...) or in both the application and the applet use the pop-up menu (right mouse button, control click on one button mouse, > Console).  In the application a window will open that looks like figure A3.1 and in the applet the window will look like figure A3.2.
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The script console is Jmol's command line interface.  In the application version type your command after the "$" prompt. The command will appear red until you have typed a complete command.  In the applet type the command in the bottom part of the window.  There is no syntax checking in the applet.  Hit the <return> key to activate the command.  Try some of these commonly useful commands:

· "spin on" will cause the molecule to start spinning.

· "spin off" will stop the molecule from spinning.

· "moveto 0 {0 0 0} 0" will return to the default view.

· "select carbon" will select the carbon atoms in the file.

· "select hydrogen" will select the hydrogen atoms in the file.

· "select all" will select all atoms in the file.

· "select none" will deselect all the atoms.

· "color green" will color all the selected atoms green.  You can pick other colors as well (blue, red, orange, violet, pink, purple, cyan,  magenta, indigo, yellow, gray, white, black).

· "measure allconnected (*)(*)" will display the bond lengths for all the bonds in the molecule.

· "set echo top left; echo "top left"" displays the text "top left" at the top left of the window.  Position options are: top left, top center, top right, middle left, middle center, middle right, bottom left, bottom center, bottom right.

· "echo """ will turn off which ever echo was last set.

· "select all; label on" will label all the atoms with their atomic symbols and atom number.

· "select none; select hydrogen; label off" will turn off just the hydrogen labels made in the previous step.

· "mo #" where # is an integer corresponding to the index of a molecular orbital will display that molecular orbtial.  The example file contains mo's #1-19, try some.

· "mo color green yellow" colors the lobes green and yellow instead of the default.

· "mo delete" gets rid of the mo.

· "isosurface vdw solvent" displays the Van der Waals surface for the selected atoms.  You will see nothing if you do not select any atoms.

· "isosurface vdw delete" will delete the surface named vdw that was created above.

· "isosurface vdw off" will turn the isosurface off without deleting it.

· "isosurface vdw on" will turn the isosurface back on.

· "isosurface list" will list the isosurfaces  you have available.

There are many more commands and the ones above have additional options.

1. Appendix 5 is a more extensive tutorial on using the echo and label commands to add text annotation.

2. Detailed documentation on all commands may be found at  Bob Hanson's Scripting Documentation[image: image16.png]


 web site.

 TC "Appendix 4: Navigating in a Multiframe File" \l 1 Appendix 4: Navigating in a Multiframe File

1. Load a file that contains multiple frames/models into the Jmol application.  You can use the staggered ethane file packaged with the .pdf version of this document:  ethane-staggered-3-21G.log.  It can also be downloaded from the tutorial web site. The example file has nine (9) different frames in it.  The first frame is the initial guess geometry that was used to start the quantum calculation.  Each frame represents an intermediate step in the calculation.  The last (#9) frame is the final optimized geometry found by the program (this is usually the case for computational geometry optimizations).  The file also contains information on energies and molecular orbitals for many of the frames.

2. There are four primary ways to navigate to particular frames (3 & 4 only work in the application):

· In the application and the applet use the pop-up menu (right mouse button, control-click on a one button mouse > Model > select the frame you wish to display).  You can also use choices in the "Animate" option of this pop-up menu.

· [image: image35.png]


Use the command line (see Appendix 3: Using Commands in the Script Window for how to access). The command is "frame #.#", where the first number is the model number (essentially the file) and the frame is the molecular information set within the file.  So for the example file "frame 1.9" will move you to the last frame;  "frame 1.7" will move you to the seventh frame; "frame 1.1" will move you to the first frame; "frame 1.0" will display all the frames at once.  Since only one file is loaded the first digit is always one in this example.

· Use the pull-down menus or buttons in the application. The menu command is (Tools > Animate... > Once) to move to the last frame.  To move one frame at a time use the buttons. Use [image: image17.png]


, the rewind button, to get to the first frame. Use [image: image18.png]


, the previous button, to go back one frame.  Use [image: image19.png]


, the next button, to go forward one frame.  Use [image: image20.png]


, the last frame button, to go to the end.

· Use the atom set chooser dialog in the application.  Be warned this dialog needs some updating.  Open the dialog using the pull-down menu (Tools > AtomSetChooser...).  You can navigate using the equivalent buttons to those in choice 1, but the set at the bottom does not work.  You can also choose a frame by clicking on it in the scrolling list of frames at the top.  See figure A4.1.
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Getting Started:

1. Load a molecule file into the Jmol application.  You can use the staggered ethane file packaged with the .pdf version of this document to follow along with this tutorial:  ethane-staggered-3-21G.log.  It can also be downloaded from the tutorial web site. 

2. Open the script window/console as annotation is best done using the command line.  In both the application and the applet open the script console using the pop-up menu (right mouse button, control-click on one button mouse, > Console).  In the application you can also use the pull-down menu (File > Script ...).

Labeling Atoms:

1. Select the atoms you want to label.

· "select none" will deselect all the atoms.  It is a good idea to use this command first to clear any previous selections.

· "select all" will select all the atoms.

· "select atomtype", where "atomtype" = carbon, hydrogen, nitrogen, etc... will select all the atoms of that type in a file.

· "select atomexpression", where "atomexpression" is an expression which can be used to select atoms within specific frames, amino acid residues and so on. Simple examples with amino acids are shown below.  More detailed information may be found in Bob Hanson's Scripting Documentation[image: image21.png]


.

2. Label the selected atoms.  

· For the ethane file I suggest starting with "select none; select hydrogen" as the initial selection.

· "label" will label all selected atoms with the default information.  The number following the "/" in the label that appears is the frame number.

· "label %a" will show just the atom symbol and index number.

· "label off" will turn off the label on the selected atoms.

· "label %e" will show just the element symbol.

· "label "your text"" will label the atom with "your text".

· Additional options may be found in Bob Hanson's Scripting Documentation[image: image22.png]


 under the label command.

Labeling Groups:

The key here is that labels are associated with particular atoms so you must select a specific atom within the group to label.  As the example here we will use a protein/DNA complex 1lcd.  A copy of a pdb file with this complex is included with the .pdf version of this tutorial as the file: 1lcd.pdb1.gz.  It can also be downloaded from the tutorial web site. 

1. Select a particular type of atom within a group.  We will select the alpha-carbon of the arginine group.  The command is "select [arg]*.CA".  The "*" indicates all arginines.  Use the standard 3 letter abbreviations for other amino acids. The ".CA" indicates the alpha carbon.  Replacing it with ".N" would select the terminal amino group; ".C" would select the carboxylic acid carbon.  To select all the nitrogens in all the arginines use "select (arg and nitrogen)".  More detailed information may be found in Bob Hanson's Scripting Documentation[image: image23.png]


.

2. To label the group as arginine once you have selected only one atom in the group use "label "ARG"".

3. This label is hard to see.  We can make it better by insisting it be in front of the atom (command "set labelfront") and making it a brighter color (command "color label yellow").

4. It is still hard to see which groups it is associated with.  We can expand them a little by making them partially spacefilling (command: "select arg; spacefill 50%").

Positioning Labels:

It is hard to see everything on a large protein structure so switch back to the ethane example for the rest of the tutorial.

1. To start label all the hydrogens (command: "select hydrogen; label %a;")

2. Center labels on atoms: "set labelalignment center; set labeloffset 0 0;"  The offset is the number of pixels in the X and Y directions from the center of the atom to the beginning of the label, so the label will start aligned with the center of the atom.

3. Make the labels float in front of the atoms: "set labelfront".  To turn this off: "set labelfront off".

4. Labels off to the left: "set labelalignment right; set labeloffset -20 0;".

5. Labels off to the right: "set labelalignment left; set labeloffset 20 0;".

Basic Floating Text (Echos):

1. To echo text in one of the nine standard positions: "set echo position; echo "your text";", where position is: top left, top center, top right, middle left, middle center, middle right, bottom left, bottom center or bottom right.  Examples: "set echo top left; echo "top left";" will display "top left" in the top left corner.  "set echo bottom center; echo "bottom center";" will display "bottom center" at the center near the bottom.

2. You can also use named echos so that you can move them around and do further manipulation.  To name an echo issue two commands in a row:

· "set echo echoname  XX% YY%", where echoname is the name you want to use for the echo and XX% and YY% are X and Y coordinates of the echo position from the bottom left in % of the applet size.

· "echo "your echo text"".

A complete example to try is: "set echo example 50% 75%; echo  "This test should appear above the ethane";"

3. You can move it to a new spot with a command like "set echo example 5% 25%"

Changing Size, Font and Color of Labels and Echos:

1. "color label blue" colors the last label added blue.

2. "color echo blue" colors the last echo that was accessed blue.

3. "font echo 24 serif bold" will make the last echo size 24 (range is 6-63), use the serif font (serif, sanserif and monospaced are the options) and make it bold faced (plain, italic and bold are the options).

4. "font label 12 monospaced italic" will make the last edited label size 12 monospaced italics.
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Because Jmol functionality depends on a Java applet and Javascript, it is only easy to install pages containing Jmol on plain vanilla web servers (ie. Apache, http://apache.org).  These instructions may not work for Microsoft servers (anybody with access to one who tests this let me know the results). If you are using a content management system (CMS) these instructions are likely to fail as most CMS installations don't allow random applets or javascript to function within them.  CMSs are also difficult to load a whole directory structure into.  Some of the Jmol team is working on embeding Jmol in wikis (see the Jmol wiki for more information). If you do not know how to add content to your web server you should discuss this with your web administrator before attempting to install Jmol.

You will need to load a number of files onto your server.  The best way to accomplish this is to make an ftp or sftp connection to your web server. Some possible software choices for file transfer are Filezilla (http://filezilla-project.org) for Windows, MacOS or LINUX, MacOS Finder for ftp, Fugu (http://rsug.itd.umich.edu/software/fugu/) for sftp on MacOS, and the standard fileviewer in most LINUX distributions.

You may install Jmol anywhere on your server that you are allowed to install files.  At a bare minimum you should install the following files in a directory dedicated to Jmol: Jmol.js, JmolApplet.jar, all JmolApplet0_...jar files, and LICENSE.txt.  You only need to install the signed applet .jar files if you wish your pages to use the applet to access files on computers other than your server.  Make sure you know where you are installing the Jmol directory as you will have to specify the path to Jmol in web pages you create.  See appendix 7 for details on the paths.
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Because Jmol functionality depends on a Java applet and Javascript, it is only easy to install pages containing Jmol on plain vanilla web servers (ie. Apache, http://apache.org).  These instructions may not work for Microsoft servers (anybody with access to one who tests this let me know the results). If you are using a content management system (CMS) these instructions are likely to fail as most CMS installations don't allow random applets or javascript to function within them.  CMSs are also difficult to load a whole directory structure into.  Some of the Jmol team is working on embeding Jmol in wikis (see the Jmol wiki for more information). If you do not know how to add content to your web server you should discuss this with your web administrator before attempting to install Jmol pages.

You will need to load a number of files onto your server.  The best way to accomplish this is to make an ftp or sftp connection to your web server. Some possible software choices for file transfer are Filezilla (http://filezilla-project.org) for Windows, MacOS or LINUX, MacOS Finder for ftp, Fugu (http://rsug.itd.umich.edu/software/fugu/) for sftp on MacOS, and the standard fileviewer in most LINUX distributions.

1. Upload the Jmol applet onto your server in the appropriate place, usually somewhere near the top of the directory structure you have access to (see appendix 6 on installing Jmol on a server).  You only need to do this once or if you upgrade your Jmol applet.

2. Upload the directory (the whole thing, not just its contents) containing your web page to a location in your server directory structure so that the path to Jmol that you specified will be correct.  See the appendix 8 on paths to the Jmol applet for more information on how to organize your server directory structure.
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Path to Jmol Applet on Server: In the top text field of the Export to Web (Jmol Web Page Maker) dialog set the relative path on the SERVER (directions to the directory) to Jmol from the directory that will contain your web page.  Use a "../" for each level you move up in the directory structure from where your page will be stored followed by names for each level down. Example: Jmol applet jar files and Jmol.js are in the directory "/www/applets/java/jmol" on the server, and you will be creating the directory "/www/yourname/thispage" to hold the HTML files and other data files. The correct path to the Jmol applet is then "../../applets/java/jmol" (up two levels to the www directory and then down to the jmol directory).

Local Path (used to test the pages on your local machine while developing them):

In the second text box of the Export to Web (Jmol Web Page Maker) dialog set the relative path on your computer to the Jmol applet.  This allows you to test the pages without uploading them to the server (on Macs you must use Safari for testing because of security issues).  The directory containing the .html file must be a subdirectory of the directory containing the Jmol applet.  There are two ways to do this:

· Simple but inefficient of disk space.  Just put a "." in this field.  A copy of the applet will be packaged in the same directory as your .html file.  This means you will have as many copies of the applet on your disk as pages generated by Jmol.

· More difficult but much more efficient.

1. Create a directory (folder) named something like "tests" inside the directory on your local machine that contains the Jmol applet.

2. Specify the local path to Jmol as "../../" when you create the page in Jmol Web Page Maker.

3. Copy or move the directory (not just its contents) containing the .html, .spt, .png and .js files for the page of interest into the directory created in step 1.

Open the .html file in the browser you want to use for testing (use Safari on MacOS X as FireFox does not pass relative paths causing a security error).  The page should work just like it would on a server.
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How you do this depends on what you set the local path to when creating the page.   See appendix 7 for details on setting the paths.

1. The local path was set to "." when the page was made: just open the .html file in the browser you want to use for testing (use Safari on MacOS X as FireFox does not pass relative paths causing a security error).  The page should work just like it would on a server.

2. The local path was set to "../../" or something else when the page was made:

· Copy or move the directory (not just its contents) containing the .html, .spt, .png and .js files for the page of interest into the testing directory you created in the same directory as the Jmol applet.  If you chose a different path you will have to figure out where to put the files for testing.  The most important constraint is that the files for testing must be below the Jmol applet in the directory tree.

· Open the .html file in the browser you want to use for testing (use Safari on MacOS X as FireFox does not pass relative paths causing a security error).  The page should work just like it would on a server.
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A list of alternatives to the built-in "export to web..." function with a few comments about them (more complete discussions of some of these may be found at the JTAT wiki):

· Server Based 

1. Protopedia.org : This is a wiki designed for people to contribute annotated and animated views of macromolecules in Jmol.  The functionality is produced inside the wiki. 

2. SChiSM2:  This is a server based templating system that allows you to have a Jmol applet controlled by buttons, with associated explanatory text.  Result looks very similar to what is produced by the "Scriptbutton" template in the Jmol "export to web..." function. 

3. International Union of Crystallography authoring kit:  This is a server based application that produces Jmol pages to be published in on line versions of their journals.  B. McMahon and R. M. Hanson "A toolkit for publishing enhanced figures", Journal of Applied Crystallography

 HYPERLINK "http://dx.doi.org/10.1107/S0021889808015616" \n _blank
 (2008). 41, 811-814. 

· Separate Software Packages or Templates 

1. JTAT: This is a template very similar to the "Scriptbutton" template in the Jmol "export to web..." function.  You will need to edit some html, plus some text in javascript files to access all of the template's functionality.  You also have to do all the bookkeeping necessary to keep track of files. 

2. Molecular Workbench:  generates tutorials in the form of java applications that can be started from a web page although they are not contained within the web page.  Molecular Workbench uses Jmol for 3-D rendering of molecules.  Some reference articles on Molecular Workbench are Q. Xie and R. Tinker, "Molecular Dynamics Simulations of Chemical Reactions for Use in Education", 

 HYPERLINK "http://search.jce.divched.org/JCEIndex/FMPro?-db=jceindex.fp5&-lay=wwwform&combo=Tinker&-find=&-format=detail.html&-skip=0&-max=1&-token.2=0&-token.3=10" \n _blank
Journal of Chemical Education

 HYPERLINK "http://search.jce.divched.org/JCEIndex/FMPro?-db=jceindex.fp5&-lay=wwwform&combo=Tinker&-find=&-format=detail.html&-skip=0&-max=1&-token.2=0&-token.3=10" \n _blank
, 83, 77-83 (2006); A. Pallant and R. Tinker, "Reasoning with Atomic-Scale Molecular Dynamic Models", Journal of Science Education and Technology

 HYPERLINK "http://www.springerlink.com/content/v067247v8x174n22/?p=cb831ca1da9841c4830754581123ac3a&pi=2" \n _blank
, 13, 51-66 (2004). 

3. JmolShell: Is a set of tools (javascript, html and Jmol script templates) one can use to build consistent Jmol tutorials.

4. Legacy tools by J. Gutow:  These are perl scripts and java applications that are no longer maintained.  Most of their functionality has been incorporated into Jmol in one way or another.  These legacy tools might serve as useful starting places for someone writing code to build web pages using Jmol. 
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Jmol home web site:  http://www.jmol.org
Jmol wiki: http://wiki.jmol.org
Bob Hanson's Jmol scripting documentation: http://chemapps.stolaf.edu/jmol/docs/
Jonathan Gutow's tools for authoring Jmol pages: http://www.uwosh.edu/faculty_staff/gutow/Jmol_Web_Page_Maker/Jmol_Web_Page_Maker.shtml
� INCLUDEPICTURE  "file:///Users/jonathan/Documents/Papers/Web%20Pages/Jmol_Web_Page_Maker/How-To/Initial_Jmol_App_View.png" \d����Figure 3: The initial view upon opening Jmol.





� INCLUDEPICTURE  "file:///Users/jonathan/Documents/Papers/Web%20Pages/Jmol_Web_Page_Maker/How-To/PopIn%20Dialog.png" \d����Figure 4: The Pop-In tab from the Export to Web (Jmol Web Page Maker) dialog.





�Figure 5: Jmol view created by "measure" command.





�Figure 6: View created by the "mo" command.





�Figure 7: Static image of the view for the first button.





�Figure 8: Static image of the view for the second button.





�Figure 9: Static image of the view for the third button.





�Figure A2.1: Static image of the view showing MO#3.





�Figure A3.1: The script window as it appears in the Jmol application.





�Figure A3.2: The script window as it appears in the Jmol applet.





�Figure A4.1: The atom set chooser dialog box.





�Figure A1.1: Image of the view of the protein as spacefilling with polar groups in red and the DNA as a cartoon.
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